History Explorer
View and Export Logged Print Job Information
Contents

Overview .................................................................................................................................. 3

Logging Information to the System Database .............................................................................. 4
  Logging Print Job Information from BarTender Designer ............................................................ 4
  Logging Application Messages ....................................................................................................... 5
  Logging Security Permission Checks ............................................................................................ 6
  Logging Printer Inventory, Print Jobs and Printer Events from Printer Maestro ....................... 7

Using History Explorer ................................................................................................................ 8
  History Explorer Views ................................................................................................................. 8
  Configuring the Interface .............................................................................................................. 11
  Search and Filtering ...................................................................................................................... 13
  Changing the BarTender System Database .................................................................................. 14

Reprinting Print Jobs ................................................................................................................... 15
  The Reprint Items Dialog .............................................................................................................. 15
  Reprinting an Entire Print Job ....................................................................................................... 15
  Reprinting Specific Item(s) .......................................................................................................... 16
  Printing a Summary of a Print Job ............................................................................................... 16

Creating Reports .......................................................................................................................... 17
  Configuring a Report .................................................................................................................... 17
  Printing a Report .......................................................................................................................... 17
  Exporting a Report ....................................................................................................................... 18
  Emailing a Report ....................................................................................................................... 18

Related Documentation ................................................................................................................. 19
Overview

Many applications in the BarTender Suite store important application-specific information in the BarTender System Database. From BarTender Designer, you can save detailed information about your print jobs or log application messages you may encounter. From Administration Console, you can log security information about who accesses an application and when. Printer Maestro lets you track printer inventory levels via the BarTender System Database.

BarTender History Explorer makes it easy to view and monitor all of this information in an organized manner. You can also generate and print reports of any data in the BarTender System Database.

History Explorer is available with the Automation and Enterprise Automation editions.
Logging Information to the System Database

History Explorer draws the information it displays from the BarTender System Database. But in order to view the information, you must first enable logging for each type of information you wish to view.

For more information on setting up the BarTender System Database, refer to the Setting Up the BarTender System Database topic in the BarTender help system.

Logging Print Job Information from BarTender Designer

History Explorer has the built-in capability to reprint one or all of the items in a BarTender print job, based solely on the print job information stored in the BarTender System Database. To use History Explorer’s reprint functionality, you must enable the logging of print job information to the BarTender System Database:

1. Open BarTender Designer.
2. From the Administer menu, select Log Setup. The Log Setup dialog opens.
3. Select the Database Log tab if it’s not already selected.
4. Enable Log To BarTender System Database.
5. Under Information to Log, enable Print Job Information and Template Data.
6. Click OK to close the Log Setup dialog.

For more information, refer to the Log Setup Dialog topic in the BarTender help system.
**Logging Application Messages**

History Explorer can display a list of messages from certain applications in the BarTender Suite, including BarTender Designer and Seagull License Server. To log these messages to the BarTender System Database:

1. Open the application whose messages you want to log.
2. From the **Administer** menu, select **Log Setup**. The **Log Setup** dialog opens.
3. Select the **Database Log** tab if it's not already selected.
4. Enable **Log To BarTender System Database**.
5. Under **Information to Log**, enable **Application Messages**.
6. From the **Severity Level** dropdown list, select the level of messages you wish to be logged.
7. Click **OK**.

![Log Setup dialog](image)

**Errors** prevent you from printing an item or from using an application in the BarTender Suite. **Warnings** are events that may affect how an item prints or an application behaves, but they are not serious enough to cause a print job to fail or an application to stop working. **Information** messages have no effect the behavior of an application or on the output of a print job.

**Custom** lets you select only specific messages to be displayed in History Explorer. For more information, refer to the **Select Messages Dialog** topic in the BarTender help system.
Logging Security Permission Checks

Every time a user attempts to perform a protected action from any BarTender application, BarTender can log the permission check. These checks can include allowed actions, electronic signatures, login overrides or encryption keys. History Explorer can display these permission checks if:

- You have set up security for your PC,
- You have set some security permissions, and
- You have enabled security logging.

For more information on setting security permissions, refer to the Security book of the BarTender help system, and the BarTender System Security white paper:

http://www.seagullscientific.com/support/white-papers

To set up security logging:

1. Open Administration Console.
2. Under Security, select the Logging node.

3. Scroll through the Action list, and enable (check) the permission checks you want logged to the BarTender System Database.
4. Click Apply to save your changes. Click OK to save your changes and close Administration Console.
Logging Printer Inventory, Print Jobs and Printer Events from Printer Maestro

History Explorer can display printer inventory events logged by Printer Maestro, as well as print jobs and printer events. To enable event logging in Printer Maestro:

1. Open Printer Maestro.
2. From the Administer menu, select Events Setup. The Events Setup dialog opens.

3. In the left Navigation Pane, select BarTender System Database.
4. Under Events, check Enable.
5. Under Event Selection, select the messages you wish to log.
6. Under Categories, enable Printer, Job and Inventory. You can enable other categories as well if you wish.
7. Click OK to close the Events Setup dialog.

For more information, refer to the Events Setup Dialog topic in the Printer Maestro help system.
Using History Explorer

**History Explorer Views**

History Explorer can be configured to display different types of information, depending on what you have selected in the View Selector pane. There are a number of available views, contingent upon which applications in the BarTender Suite you have installed and where you have enabled logging.

**BarTender Suite: Messages**

When you select one of the filtering options in the **BarTender Suite: Messages** view, History Explorer displays a list of messages that are stored in the BarTender System Database from all applications in the BarTender Suite that have message logging enabled.

![BarTender History Explorer](image)

**BarTender: Print Jobs**

The **BarTender: Print Jobs** view displays all jobs you have printed in BarTender. By default, they are listed chronologically in the order that they were printed. Simply click on a job to view detailed print information, images of your items and status history.

You can reprint any job by selecting **Reprint** from the print job's context menu.

At the beginning of each job record is a plus or minus icon. The plus icon (⊕) lets you "drill down" and see more advanced information relating to that particular print job, while the minus icon (⊖) "hides" the additional information from view.
**Printer Maestro: Print Jobs**

Like the BarTender: Print Jobs view, the Printer Maestro: Print Jobs view displays information about all print jobs sent from your computer. Whereas the BarTender: Print Jobs view shows only BarTender print jobs, this view shows print jobs sent from any application on your computer, as long as you are connected to the Printer Maestro service.

As before, the plus icon (⊕) lets you view detailed Status History for a selected print job.
**Printer Maestro: Printer Events**

When the Printer Maestro service detects a printer event, it stores this as a field in its database. The *Printer Maestro: Printer Events* view lets you list these events by printer, so you can easily monitor the printers installed on your computer.

![Printer Maestro: Printer Events](image1)

**Printer Maestro: Inventory Events**

Printer Maestro can be used to track printer inventory, such as printer stock, ink or toner, or hardware parts. When one of these tracked inventory levels changes status, the events can be viewed using the *Printer Maestro: Inventory Events* view.

![Printer Maestro: Inventory Events](image2)

**Security Center: Permission Checks**

The *Security Center: Permission Checks* view displays the security permission checks made by applications in the BarTender Suite. These checks can include allowed actions, electronic signatures, login overrides or encryption keys.

![Security Center: Permission Checks](image3)
Configuring the Interface

Like most other applications in the BarTender Suite, you can configure the layout of History Explorer by sorting, adding, removing and resizing columns and panes.

Columns

Columns in the interface can be sorted, grouped and configured in a number of ways:

- **Sort columns**: Click to sort the contents of a column. Click to reverse the sort.
- **Reposition a column**: Simply drag the heading left or right using your mouse.
- **Remove an existing column**: Right-click any column header to display a list of available columns. Uncheck any column that you don't want to appear in the interface.
- **Add a column**: Right-click on any column header to display a list of available columns. Click on any unchecked column to display it.
- **Resize a column**: Mouse over the side of the column heading. When you see the resize cursor , click and drag the column to change its width.
- **Group columns**: From a column header’s context menu, select Show Group By Box. When the box appears, drag the column header to the box. The contents of the column appear in the central display pane, where you can expand each item to view details.

Panes

Panes can be resized, moved, floated or pinned.

- **Resize panes**: Mouse over the side, top, or bottom of the pane. When you see the resize cursor ( or ), click and drag the pane to change its width.
- **Move panes**: You can move and re-dock panes into different locations on the screen, or leave one or more panes floating over the other panes. To move a pane, click the pane name, and drag it in the direction you want to move it. Select the docking arrow to place the pane.
- **Float panes:** If you move a pane out of place but don't select a docking arrow, it will "float" above the other panes. You can even move it out of the History Explorer window to examine it separately. To dock a floating pane, move it back to the History Explorer window and select a docking arrow.

- **Remove panes:** Click the x at the upper-right corner of a pane to remove it from the History Explorer window. You can also select which panes to display from the View menu. You can restore the interface to its original configuration at any time by selecting **Restore Default View** from the View menu.

- **Un-pin panes:** Click the vertical pin \( \Rightarrow \) at the upper-right of a pane to "roll it up" into a tab along the side of the History Explorer window, getting it out of the way of the other panes. Hover your mouse over the tab to view the pane. To pin a pane back into place, click the horizontal pin \( \Rightarrow \) at the upper-right of the pane when the pane is visible.
**Search and Filtering**

There are a number of ways to search for and filter the data supplied by History Explorer.

The **BarTender Suite: Print Jobs** view is the only view with an actual search field. It searches every object in every print job within the specified time frame for the specified text.

![Search and Filtering](image.png)

All views in History Explorer have a navigation bar which lets you navigate through the entries for the open view.

![Navigation Bar](image.png)

Alongside History Explorer’s search functionality, you can use one of the application’s built-in filter tools to help narrow down the results that appear. Each view contains commonly used filters as sub-categories in the View Navigator. If these don’t meet your filtering needs, you can set up custom criteria using the **Custom** view.

![Filtering](image.png)

Furthermore, each results pane contains the following filter tools:

- **Filter button**: Located in the top right corner of each column heading, this button lets you filter the data by one key word.
- **Time Span**: All History Explorer views have a **Time Span** dropdown, where you can filter the results down to the specified time frame.

For more information on filtering data, refer to the **Filtering** topic of the BarTender help system.
Changing the BarTender System Database

Different instances of BarTender can be configured to log to different System Databases. You can change the system database you’re connected to in order to view information from a different instance of BarTender.

1. From the File menu, select Disconnect System Database.
2. Again from the File menu, select Connect to System Database. The Connect to BarTender System Database dialog opens.

3. Use the dropdown menus to choose a new system database, and click Connect. If you haven't previously connected to other databases, the fields will be blank, and you'll need to manually connect to the new database:

   a. From the System Server dropdown list, select <browse for more...>. The Browse for BarTender System Servers dialog opens.
   b. Select the system server you want, and click OK to close the dialog.
   c. In the Database field, enter the name of an existing BarTender database, and click Connect.
Reprinting Print Jobs

The Reprint Items Dialog

History Explorer can, regardless of where the print job originated, redirect any reprint job to any computer on the network, and/or any network printer. The Reprint Items dialog, which appears whenever you reprint items from History Explorer, lets you change the computer from which you want the print job to originate or change the printer so that you don’t have to re-create the original hardware and software configuration. Even if you want to use a completely different brand of printer that uses a different printer language, you can still use it to reprint items from past print jobs.

Reprinting an Entire Print Job

To reprint an entire print job, locate the job in the BarTender: Print Jobs pane. Select Reprint from the print job’s context menu.
Reprinting Specific Item(s)

If you wish to reprint only sections of a print job, you can do so by specifying the exact items you want to reprint.

From the Selected Print Job Details Pane

1. Click a listed print job. The Selected Print Job Details pane and the Printed Item Image pane open.
2. From the list of page numbers, printed items, and objects, select the Printed Item you wish to reprint.
3. Click the Reprint icon to open the Reprint Items dialog.

You can also select Reprint Item from the context menu of the selected item.

From the Printed Item Image Pane

When you select an item in the Selected Print Job Details pane, a preview image of that item shows up in the Printed Item Image pane. To reprint only this item, click the Reprint icon or select Reprint Item from the image’s context menu.

Printing a Summary of a Print Job

To print a detailed report of the selected print job, click the Overview tab of the Selected Print Job Details pane. The Print icon will open a preview of the report. From here, you can configure the report with a header or footer, print it, save it to a file or email it using your default email application.
Creating Reports

You can create reports of print jobs and security checks for any view in History Explorer's View Selector. For example, you could print a report showing all BarTender print jobs, jobs by computer or jobs by document. This is a good way to pass along print history information to managers, as well as other teams and departments.

To create a report of the active view, select Export View from the File menu.

![Image of a report showing BarTender print jobs]

Once you've created the report, you can configure, print, export (save) and/or email it from the Preview window.

Configuring a Report

Many of the options in the toolbar let you configure your report so that you can configure the appearance and printer settings, as well as group the data on the report. Examples of these custom configurations include adding a header, footer or watermark, changing the background color or changing the page setup. Advanced settings are accessed using the Customize icon on the toolbar.

Print Options

Each report has a set of print options that define how your data is displayed in the report. The Print tab lets you define what data is printed, and how it is separated. You can choose to print or remove separator lines, headers and footers summarizing the data, or detailed information about each entry in the database. From here, you can also select what rows are printed or filter the data in your report.

The Behavior tab defines the printing behavior for your report. Here, you can define the width of the report, display all sub-grids or set a formatting style for your report.

Printing a Report

You can quickly print the report without opening the Print dialog by clicking the Quick Print icon 📑. To open the Print dialog prior to printing, click Print 📑.
**Exporting a Report**

You can export (or save) the report in many different formats, and to any location on your computer or network.

1. From the **File** menu, select **Export Document**. A list of file types appears.
2. From the list, select the format you want. An **Options** dialog specific to that format opens.
3. Edit the format options and click **OK**. The **Save As** dialog opens.
4. Select the location where you wish to export (save) the file, and edit the file name if you wish.
5. Click **Save**.

**Emailing a Report**

You can email the report in many different formats.

1. From the **File** menu, select **Send via E-Mail**. A list of file type appears.
2. From the list, select the format you want. An **Options** dialog specific to that format opens.
3. Select the location where you wish to save the file, and edit the file name if you wish.
4. Click **Save**. Your email client opens, with the file already attached.
Related Documentation

White Papers and Manuals
- BarTender System Security
- Reprint Console
- Printer Maestro

For downloadable versions, visit:

http://www.seagullscientific.com/support/white-papers

BarTender Help System
- History Explorer
- Logging Application Messages
- Logging Permission Checks